09 Heat output

Kbar Dec 6, 2017

  1. Kbar

    Kbar Test Drive

    Messages:
    3
    Location:
    Amherst, WI
    Hey guys,

    New to this site and also new Xterra owner, have an issue now that winter is upon us here in Wisconsin.
    I start up my X to warm up and found that very little heat is flowing, drove down driveway 30 or so yards and the heat starts flowing. Temp gauge was in normal mid range. Does the water pumps on these things not flow well until you give motor some R's? While driving it throws heat like nobodies buisness! Never had a problem like this with any vehicle before.
    To be more specific I have an 09 Xterra S. Any help would be appreciated.



    --Kbar
     
  2. maillet282

    maillet282 Suspension Lift Supporting Member

    Messages:
    3,089
    Location:
    Ontario Canada
    sounds like there might be an air bubble in your coolant system. first off, check to see if there is enough coolant in the overflow tank of the radiator. I can't remember the exact procedure to "burp" somebody should be around shortly with the rest of the info. I am away for my normal computer with all of the appropriate links at the moment
     
  3. JeffPro4x

    JeffPro4x Titan Swapped / SAS'd Moderator Supporting Member

    Messages:
    7,649
    Location:
    Glenside, PA
    The 1st step is to check your coolant level. Engine idling and hot. Coolant should be at Max level. If not, add coolant then rev engine or drive for a bit. If heat works ok after that, your good. If not, check coolant level again, you might have to repeat the process a couple of times. Just did it tonight
     
  4. jg8992

    jg8992 Hi, my name is Brandon Supporting Member

    Messages:
    10,491
    Location:
    Spotsylvania, VA
    Had to do it when I first bought the X
     
  5. jg8992

    jg8992 Hi, my name is Brandon Supporting Member

    Messages:
    10,491
    Location:
    Spotsylvania, VA
    also Nissan has their own special coolant should be blue. They don’t recommend mixing anything else in only genuine Nissan “lifetime” coolant
     
  6. Kbar

    Kbar Test Drive

    Messages:
    3
    Location:
    Amherst, WI
    Unbelievable coolant was at min level(my brain was telling me cold/full) added maybe a pint of fluid.....now has heat while sitting idling. Never would have given that a second thought. Thanks guys you've been a great help!

    jg8992...My coolant was changed at some point to red coolant. Have only owned the X for about 3 months, first Nissan ever.
     
    JeffPro4x likes this.
  7. JeffPro4x

    JeffPro4x Titan Swapped / SAS'd Moderator Supporting Member

    Messages:
    7,649
    Location:
    Glenside, PA
    Yeah. Only way to check is idle and hot. Has something to do with our coolant system being a closed system. In not too proud to say that I don't quite understand it.
     

Share This Page