1. With the change in forum software we are no longer supporting Tapatalk. Please check us out on your mobile browser, we think you'll like how the site works.
    Dismiss Notice

Aftermarket stereo affecting keyless entry

J Everett May 5, 2017

  1. J Everett

    J Everett Suspension Lift Supporting Member Founding Member

    Messages:
    2,600
    Location:
    Houma, LA
    Both times that I've installed aftermarket stereos in this truck (a Pioneer nav unit and now a Chinese Android stereo) I've experienced a weird delay in the keyless entry. Both units are, in essence, computers and take about 30 seconds to shut down completely. Within that 30 second window, keyfob will only lock/unlock while standing right next to the truck. After the stereo is completely shut down, it will work at normal ranges. I thought it was the fob at first, but I have 4 fobs and a key code pad and it's the same with all of them, even with fresh batteries. I didn't realize it was related to the stereo until after I pulled the Pioneer and went back to stock for a few months.

    Am I the only person to experience this? Anyone have any idea how to fix it without going back to the stock stereo?
     
  2. Prime

    Prime Some Kind of In Charge? Admin

    Messages:
    28,639
    Location:
    Portsmouth, VA
    That is really strange. I have an android radio in mine also, and I haven't noticed it affecting the key fobs at all. I was having some battery issues with my Chinese key fob, but a battery fixed that.

    I can't think of any wires that run to the BCM from the radio.
     
  3. J Everett

    J Everett Suspension Lift Supporting Member Founding Member

    Messages:
    2,600
    Location:
    Houma, LA
    I'm actually wondering if it isn't some form of RF interference.
     

Share This Page